Issue with Vent Control Knob

Discuss any problems, warranty, repair, or replacement issues you are having with your Vibe & Matrix
Post Reply
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Issue with Vent Control Knob

Post by gtv237 »

Hello, I've been having an issue with my vent select knob for a little while now. It feels sort of like its jamming but now it won't go into defrost at all. I took it apart and found that the plastic cable sheathing is broken near the knob. I looked it up online and there are two different part numbers, 5590926080 and 5590626060. There are two cables. One for the vent control and one for the temperature control (hot/cold). I just can't figure out which is which. They look identical. Can anybody help me with this? I suppose it wouldn't be the worst idea to just replace both.

Image

Image
jolt
Posts: 922
Joined: Sun Mar 02, 2014 2:07 am
Location: Twin Cities, Minnesota

Re: Issue with Vent Control Knob

Post by jolt »

What I could find was that the Toyota #5590926080 was marked as "air mix" and Toyota #5590626060 was marked as "temp". This info was from a web site selling Toyota parts.
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

jolt wrote:What I could find was that the Toyota #5590926080 was marked as "air mix" and Toyota #5590626060 was marked as "temp". This info was from a web site selling Toyota parts.
Thanks for taking the time but I did already see that. Air mix and temp control are just two ways of saying the same thing. Oh well. I already bought both. I'll report back with which is which. Thanks again.
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

Well as it turns out 5590626060 is for the mode/vent direction and 5590926080 is for the temperature control/heater core door. Just for anyone else who has this problem in the future. The cables are about $30 each from the Toyota dealer. You can get them for about $20 each plus shipping from various venders online.

On a side note I decided to do a little upgrade while I had it all apart. I always thought the climate controls looked a little cheap so I took the nicer looking controls from a 2013 Toyota Yaris. Everything was plug and play. The only real difference is that the rear defrost is on a timer for the yaris where as its just a toggle switch on the vibe. I think it looks really nice, gives it a more premium feel.

Image

Image

Image

Image
User avatar
trb
Posts: 1670
Joined: Thu May 08, 2008 4:06 am
Location: Houston, TX

Re: Issue with Vent Control Knob

Post by trb »

Looks nice! I did notice that the Yaris had the same basic controls as my 2010 Vibe when my son had a Yaris as a rental. There are a lot of little "upgrades" that can be done to some cars to make them look better. I did the same on my 87 Mustang, swapping to a later model AC control panel, and then I swapped the knobs for different ones from a Taurus!
Thomas
the "Mustang Guy"
1987 5.0 LX Mustang
2016 Mustang GT - current daily
2004 Satellite Vibe &
2009 Red Vibe GT -twin's cars
2003 Neptune Vibe GT - prior daily
2010 Red Vibe GT - RIP 6/16/14
2006 Platinum Vibe - son's car
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

gtv238 wrote:On a side note I decided to do a little upgrade while I had it all apart. I always thought the climate controls looked a little cheap so I took the nicer looking controls from a 2013 Toyota Yaris. Everything was plug and play. The only real difference is that the rear defrost is on a timer for the yaris where as its just a toggle switch on the vibe. I think it looks really nice, gives it a more premium feel.
I am so doing this on our Vibes! I agree it looks more premium and the extra little bit of chrome goes great with the chrome rings on the vents and the chrome shift knob overlays we have.

So, do you have part numbers for the knobs? How does the installation work since you said the Vibe has toggle switch and the Yaris has a timer for the rear defrost? Any more info, or heck... a how-to, would be great! Thanks a ton :D!
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

vibenvy wrote: So, do you have part numbers for the knobs? How does the installation work since you said the Vibe has toggle switch and the Yaris has a timer for the rear defrost? Any more info, or heck... a how-to, would be great! Thanks a ton :D!
Sorry I don't have the part numbers. I don't know if you can buy the knobs separate from the controls. The controls themselves would probably be quite pricey from the dealership. I just went on eBay and got the whole climate control panel for $60. Everything was mint because it was from a 2013.

As far as installation, it really is 100% plug and play, no modification or wiring necessary. The Yaris's defrost timer is integrated into the control. All it does is turn the rear defroster off on its own after a certain amount of time. If you end up doing this mod my only advice is just be careful with the control cables! They are oh so fragile.
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

removed
Last edited by vibenvy on Sat Apr 11, 2015 4:44 am, edited 1 time in total.
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

Wow, you're a lot better at the Internet than I am.

Here's the final tweak to my new controls. White LED's instead of orange bulbs. It matches the instrument cluster very well.

Image

Image

Image
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

I heard back from TRD Sparks. Unfortunately, #55406-52330C0 is just the bezel.

They did include the part numbers for the individual knobs though if anyone's interested (they did not specify which part number is for which knob)...

#55901-52400 = $68.52
#55902-52220 = $72.23
#55903-52650 = $54.17

Obviously at those prices I will be watching eBay to get a used bezel and knobs like gtv did.

@ gtv237: The white LEDs do look really good! Do you have a link for the LEDs you used? Thanks again for all your help ;)!
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

vibenvy wrote:I heard back from TRD Sparks. Unfortunately, #55406-52330C0 is just the bezel.

They did include the part numbers for the individual knobs though if anyone's interested (they did not specify which part number is for which knob)...

#55901-52400 = $68.52
#55902-52220 = $72.23
#55903-52650 = $54.17

Obviously at those prices I will be watching eBay to get a used bezel and knobs like gtv did.

@ gtv237: The white LEDs do look really good! Do you have a link for the LEDs you used? Thanks again for all your help ;)!
The bulb type is T4. I got mine on eBay. Just search T4 LED and the color you want.

Just wanted to share another picture. These do look really cool in person! :mrgreen:

Image
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

gtv237 wrote:The bulb type is T4. I got mine on eBay. Just search T4 LED and the color you want.
I was just looking at this thread again and decided when I switch the HVAC knobs out for the Yaris ones, I'd also like to swap the bulbs out with white LEDs like you did. I've had very good luck with v-LEDs, so I'd like to order from them instead of eBay. These are the only white T4 LEDs they have, so I'll more than likely go with them. Now, how many bulbs did you replace? I'm assuming three, but want to make sure before I order anything. Thanks in advance!
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

vibenvy wrote:
gtv237 wrote:The bulb type is T4. I got mine on eBay. Just search T4 LED and the color you want.
I was just looking at this thread again and decided when I switch the HVAC knobs out for the Yaris ones, I'd also like to swap the bulbs out with white LEDs like you did. I've had very good luck with v-LEDs, so I'd like to order from them instead of eBay. These are the only white T4 LEDs they have, so I'll more than likely go with them. Now, how many bulbs did you replace? I'm assuming three, but want to make sure before I order anything. Thanks in advance!
You are correct. There is only one per control. So 3 total.
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

Okay. Thanks! Do the A/C, recirc and defroster buttons share bulbs with their respective knobs or do they have their own seperate bulbs?

I am thinking this will be getting done sooner rather than later because I am super excited and anxious to do it :P! I am also going to get a white LED bulb to put in the shift indicator so it will match the HVAC and gauges.
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
User avatar
vibenvy
Posts: 7121
Joined: Wed Apr 15, 2009 5:38 am
Location: Sandwich, IL

Re: Issue with Vent Control Knob

Post by vibenvy »

Thanks again gtv! Got my mom's Vibe done yesterday and mine are due to arrive later this week.

Image

Image

Image

Image
Image
2009 Liquid Platinum Metallic Vibe GT - 5-Speed Auto – Garage
2009 Steel Blue Metallic Vibe GT - 5-Speed Auto – Garage
gtv237
Posts: 387
Joined: Fri May 23, 2014 6:21 pm

Re: Issue with Vent Control Knob

Post by gtv237 »

vibenvy wrote:Thanks again gtv! Got my mom's Vibe done yesterday and mine are due to arrive later this week
Looks great Carrie. Glad I could contribute!
JetBlack
Posts: 38
Joined: Wed Jul 20, 2016 10:28 am
Location: Sacramento CA
Contact:

Re: Issue with Vent Control Knob

Post by JetBlack »

I'm a new Vibe here a bit late to the party, The LED mod is very interesting, gonna order parts from them before the end of the week.

My toggle light had gone bad has anyone had luck in replacing them? (if they are even replaceable). I've been having a bit of trouble with the A/C switch its stuck ON if am not able to replace it might try the Yaris controls mod too.

Thanks for all the information guys! Would contribute soon.
Image
Join the VibeTribe on Drive Tribe https://drivetribe.com/t/LGVEe7TeQceVCW ... rTPsS40_rQ
2009 Vibe 2.4l Premium Package w/ Roof Rails
JetBlack
Posts: 38
Joined: Wed Jul 20, 2016 10:28 am
Location: Sacramento CA
Contact:

Re: Issue with Vent Control Knob

Post by JetBlack »

gtv237 wrote:
vibenvy wrote:I heard back from TRD Sparks. Unfortunately, #55406-52330C0 is just the bezel.

They did include the part numbers for the individual knobs though if anyone's interested (they did not specify which part number is for which knob)...

#55901-52400 = $68.52
#55902-52220 = $72.23
#55903-52650 = $54.17

Obviously at those prices I will be watching eBay to get a used bezel and knobs like gtv did.

@ gtv237: The white LEDs do look really good! Do you have a link for the LEDs you used? Thanks again for all your help ;)!
The bulb type is T4. I got mine on eBay. Just search T4 LED and the color you want.

Just wanted to share another picture. These do look really cool in person! :mrgreen:

Image

Does dimming still work with these LEDs?
Image
Join the VibeTribe on Drive Tribe https://drivetribe.com/t/LGVEe7TeQceVCW ... rTPsS40_rQ
2009 Vibe 2.4l Premium Package w/ Roof Rails
User avatar
MacGyver
Posts: 340
Joined: Sat Apr 30, 2016 2:45 pm
Location: Ottawa (09 Base)

Re: Issue with Vent Control Knob

Post by MacGyver »

JetBlack wrote:Does dimming still work with these LEDs?
I did my 09 a few weeks ago and they dim just fine.
2009 Vibe Base
BossTech
Posts: 2
Joined: Sun Oct 16, 2016 12:57 pm

Re: Issue with Vent Control Knob

Post by BossTech »

I have the same problem with my 09 Vibe 2.4L. I was all optimistic when I saw this thread as it describes the problem well and I went out and got the cable (5590626060 ) but it did not describe how to fix it.

I have it all apart now and have followed the cable to the other end to the part that has the gear that matches the vent control. It's in tight between the heater box and the blower motor case. I have wiggled it out of the position but can't get it to come out. With that crevice of space to work in, I'm not sure how the "putting back" is going to work if I ever get it out.

Is there some way to move the blower motor assembly to the right or drop the heater box to get it. I'm sure a 1/4 " or 1/2" of extra room is all I need.

Shops are estimating 5 - 6 hours labour @ $125 hr. The part was $61. CDN

Will provide pictures later if necessary.
JetBlack
Posts: 38
Joined: Wed Jul 20, 2016 10:28 am
Location: Sacramento CA
Contact:

Re: Issue with Vent Control Knob

Post by JetBlack »

MacGyver wrote:
JetBlack wrote:Does dimming still work with these LEDs?
I did my 09 a few weeks ago and they dim just fine.
Awesome I would be getting Rav4 Climate controls on the vibe next week with stock LEDs. I would post up my images too soon.
Image
Join the VibeTribe on Drive Tribe https://drivetribe.com/t/LGVEe7TeQceVCW ... rTPsS40_rQ
2009 Vibe 2.4l Premium Package w/ Roof Rails
tpollauf
Posts: 3879
Joined: Wed Jan 20, 2010 11:37 am
Location: Toledo/Oregon, Port Clinton Ohio
Contact:

Re: Issue with Vent Control Knob

Post by tpollauf »

FYI .... I just experienced this exact problem in my son's 2009 Vibe GT. After careful moving back and forth in both directions, I was able to free up the selection process. I simply went out to move his car and wanted to take it off of DEFROST but it was stuck there. This may become a common problem in our Vibes as they get older.
Image
2009 Vibe GT (manual), 2009 G8Gt, 2009 Vibe GT (auto)
2014 Silverado, 2004 Vibe GT, 2003 Vibe GT (project car)

"everything is modifiable"
Owim
Posts: 46
Joined: Mon Apr 28, 2014 3:57 pm

Re: Issue with Vent Control Knob

Post by Owim »

I had this problem where I couldnt get into defrost. It turned out the evaporator box that controls where the airflow goes had a broken gear so the little slider thing was only working on one end. exspensive fix
2009 2.4 AWD
butlerjonas
Posts: 30
Joined: Fri Feb 05, 2021 8:31 pm

Re: Issue with Vent Control Knob

Post by butlerjonas »

Hey everyone. It's four years later, but I'm just now having similar problems with my '09 Vibe GT. The air direction knob still works, but it's very hard to turn. Also, my temperature door seems to not be closing all the way, so I'm getting no less than 100 degree air unless the AC is on. I can't see any of these pics anymore, but if anyone can help me with this, I'd really appreciate it!
09 Vibe GT
2AZ-FE 2.4L (upgraded pistons)
Valvoline MaxLife Full Synthetic 5w-20/Toyota TRD filter
Valvoline MaxLife ATF
Toyota/Denso air filter
NGK Laser Iridium spark plugs
Broken volume knob
Vibration at idle
ent3rix
Posts: 2
Joined: Mon Apr 17, 2017 8:12 am

Re: Issue with Vent Control Knob

Post by ent3rix »

I had this issue with my 2010. My temperature control cable got damaged/stretched as there was somehow a glow stick stuck in the blend door.

This is for the far right control knob with the AC switch/light.

5590926080 was the correct replacement cable - ebay for $22. Pop out the central dash and glovebox, pull the HVAC panel and remove the old cable. I also popped off the passenger floor vent of the blend box for more working room.

When you're installing the new cable & gear it's a bit difficult to feed through.

There is a hole that needs to line up with the new gear and it will snap in. You also need to make sure the black and white gears mate up at the "square" cog. My photo shows it NOT lined up properly and needing to be rotated.

Inked2010 Vibe.jpg
Inked2010 Vibe.jpg (729.84 KiB) Viewed 127 times
Post Reply