Got new po's after replacng the IAC

1.8-liter VVTL-i (2ZZ-GE) and VVT-i (1ZZ-FE) engine, transmission, exhaust, intake, and performance tuning discussions
Post Reply
salamander162
Posts: 49
Joined: Mon Nov 09, 2020 5:24 am
Location: Lone Star State

Got new po's after replacng the IAC

Post by salamander162 »

i was having problems with the engine accelarating when started in the mornings from 1,200 up to 2,000 so i replace the IAC and that solved the problem but now i got new codes: PO441,442 and 446. what is wrong now?
User avatar
joatmon
Posts: 10020
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: Got new po's after replacng the IAC

Post by joatmon »

those are related to not being able to put a vacuum on the gas tank, part of the evaporative emissions control

One of my vibes threw some of those codes, was never able to solve it, so I just kept my code reader hooked up and cleared the CEL whenever it came up, so I'd be able to tell if something else happened to cause a CEL.

It can be something simple as a gas cap not screwed on tight, or as evasive as a pinhole in a hose somewhere. Since the new codes came up after you did work on it, hopefully yours will be something like a vacuum hose not hooked up or hooked up wrong
Image
salamander162
Posts: 49
Joined: Mon Nov 09, 2020 5:24 am
Location: Lone Star State

Re: Got new po's after replacng the IAC

Post by salamander162 »

thanks for the info, i'll check those hoses !
those codes doesn't affect the inspection?
User avatar
joatmon
Posts: 10020
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: Got new po's after replacng the IAC

Post by joatmon »

salamander162 wrote: Sat Mar 18, 2023 3:49 pm
those codes doesn't affect the inspection?

I live in a county that doesn't require periodic emissions testing, but I'd bet money they'd cause inspection to fail
Image
salamander162
Posts: 49
Joined: Mon Nov 09, 2020 5:24 am
Location: Lone Star State

Re: Got new po's after replacng the IAC

Post by salamander162 »

after all it was just a simple thing: clean the gas cap

so thanks guys for the help and info
User avatar
joatmon
Posts: 10020
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: Got new po's after replacng the IAC

Post by joatmon »

The best fixes are the ones that don't cost. Hope you have lots of CEL-free miles ahead
Image
Post Reply