Cooling fan is on at fast speed when engine is cold and A/C is on

Discuss any problems, warranty, repair, or replacement issues you are having with your Vibe & Matrix
Post Reply
lexicon
Posts: 121
Joined: Sat May 06, 2006 3:48 pm

Cooling fan is on at fast speed when engine is cold and A/C is on

Post by lexicon » Wed Jul 21, 2021 7:39 am

2006 Vibe 1.8 base engine. 230k miles. This is not normal for my car. When engine is cold, and I turn on the A/C, the engine fan is at high speed 100 % of the time , this also happens when the defrost setting is selected.
I have pulled fan relay number 1 and 2 and checked. They are OK. If I dont turn on the A/C, the fan does not come on automatically when the engine is cold.
I've read that the A/C pressure switch has control of the fan, but I am just shooting in the dark.
I had the Delco compressor replaced (clutch came apart) several years ago and since it uses Delco parts, I assume the pressure switch is also Delco....
The A/C system does blow cold air , no problem there.
Has anyone had a similar problem ?
I am concerned that the fan running non-stop at fast speed for hours when driving will take its toll on the fan.
Any help is appreciated.
Am posting here since this is the problem /troubleshooting area of the forum.
Thanks
2005 VibeAutomaticStockNon AWD125 hp model

andrewclaus
Posts: 338
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: Cooling fan is on at fast speed when engine is cold and A/C is on

Post by andrewclaus » Thu Jul 22, 2021 4:28 am

My '07 base Vibe does the same thing, and has since I bought it four years ago. My old Subaru does the same thing too. I live in a dry, fairly temperate climate and seldom use the A/C so it's never bothered me. It also happens on defrost and that's normal.

I don't have the exact wiring diagram for the VIbe, but a similar system for the same year Corolla shows the pressure switch is in the fan control system, as well as the ECU. I don't know the exact pressure switch function, but it sure looks like when there's pressure in the coolant system the radiator fan switches to high speed, by design. Perhaps your car had a coolant pressure problem earlier, now resolved. Or perhaps my car has a problem and I don't know it.

I wouldn't worry about the fan motor at high speed vs low. At high speed, a resistor is switched out of the circuit, so in a way high fan speed is prolonging the life of the resistor.

lexicon
Posts: 121
Joined: Sat May 06, 2006 3:48 pm

Re: Cooling fan is on at fast speed when engine is cold and A/C is on

Post by lexicon » Thu Jul 22, 2021 6:14 pm

Hi,
this fellow in the link had exactly the same issue with his Vibe. He had two vibes, one had this same issue, his other one did not.
He has not posted since 2018 and he may not even come to Genvibe anymore, but, If i had his email address, I would ask him.
Ive done extensive searches and have come up empty except for the link below.
Since this is a Delco A/C system and not a Toyota, this may not be an issue the Matrix or Corollas had.
Any suggestions are appreciated.
In the link below, he did not reference any solution.



https://forums.genvibe.com/phpBB3/viewtopic.php?t=46497
2005 VibeAutomaticStockNon AWD125 hp model

Post Reply