Airbag Light after HU install

Stereo, security systems, vehicle electronics, and electrical-related discussions

Airbag Light after HU install

Postby silvrhawk7 » Mon Jan 05, 2009 10:18 pm

I just installed a new sony HU (will have Pics to come) However shortly after the install, my Drivers side airbag light came on steady I dont recall pulling on any wires, and have not been able to check the fuses yet. Is there any data on the stock unit that talks to the computers that would relate to this. I also checked the search and could not find anything direct to this issue.

2006 Silver Mono, Base 4-Speed auto, 16" Alloys On Michelin Primacy Tires
Mods?? TBI Coolant Bypass (Thanx V) DRL Bypass, Led Cup holders (Thanx DominosChris), Sony Head Unit
Next on the list: Operation Glasshatch Release.

In Memory of Pontiac Motor Division 1926-2010
In Memory of the Pontiac Vibe 2002-2009
GM, not only have you Lost me as a customer but you have lost millions more....

User avatar
silvrhawk7
 
Posts: 264
Joined: Wed Jan 17, 2007 10:19 am

Re: Airbag Light after HU install (silvrhawk7)

Postby cerulean » Mon Jan 05, 2009 10:57 pm

Check that the plug is fully connected to the airbag indicator on the radio bezel.

Bob

cerulean
 
Posts: 42
Joined: Fri Mar 30, 2007 8:28 am

Re: Airbag Light after HU install (silvrhawk7)

Postby Sublimewind » Mon Jan 05, 2009 11:57 pm

Quote, originally posted by silvrhawk7 »
I just installed a new sony HU (will have Pics to come) However shortly after the install, my Drivers side airbag light came on steady I dont recall pulling on any wires, and have not been able to check the fuses yet. Is there any data on the stock unit that talks to the computers that would relate to this. I also checked the search and could not find anything direct to this issue.

They shouldn't be related in any way... Did you do a proper install with a harness to plug into the car? the only thing that I could think of being a possibility is that something got shorted, but it's a slim one... more info on the install process might help though...

User avatar
Sublimewind
 
Posts: 5140
Joined: Thu May 24, 2007 4:44 am

Re: Airbag Light after HU install (Sublimewind)

Postby silvrhawk7 » Tue Jan 06, 2009 12:34 am

I connected the wires as the diagram was shown with the hardware. the light didnt come on right away though, and yes the plug on the bezel is connected.

Now I know that there are two connectors to the Stock HU, the black one apparently isnt used for Aftermarket Installs, however does that send data to the stereo from the ECM or the Airbag Computer??


2006 Silver Mono, Base 4-Speed auto, 16" Alloys On Michelin Primacy Tires
Mods?? TBI Coolant Bypass (Thanx V) DRL Bypass, Led Cup holders (Thanx DominosChris), Sony Head Unit
Next on the list: Operation Glasshatch Release.

In Memory of Pontiac Motor Division 1926-2010
In Memory of the Pontiac Vibe 2002-2009
GM, not only have you Lost me as a customer but you have lost millions more....

User avatar
silvrhawk7
 
Posts: 264
Joined: Wed Jan 17, 2007 10:19 am

Re: Airbag Light after HU install (silvrhawk7)

Postby Sublimewind » Tue Jan 06, 2009 2:05 am

Quote, originally posted by silvrhawk7 »
I connected the wires as the diagram was shown with the hardware. the light didnt come on right away though, and yes the plug on the bezel is connected.

Now I know that there are two connectors to the Stock HU, the black one apparently isnt used for Aftermarket Installs, however does that send data to the stereo from the ECM or the Airbag Computer??

It shouldn't, they shouldn't be related AT ALL... that's why I asked about the harness, cause some people will hack into the factory radio harness, being either to cheap or to dumb to buy the proper reverse harness for the car.. often times, this doesn't end well...lol... but even still, it shouldn't have anything thing to do with it and there shouldn't be anything really near by to harm...

All harnesses related to the airbags are all bright yellow in color, did you disturb anything in bright yellow wire loom?

User avatar
Sublimewind
 
Posts: 5140
Joined: Thu May 24, 2007 4:44 am

Re: Airbag Light after HU install (Sublimewind)

Postby kunkstyle » Tue Jan 06, 2009 5:21 am

Quote, originally posted by silvrhawk7 »
I just installed a new sony HU (will have Pics to come) However shortly after the install, my Drivers side airbag light came on steady

If it came on shortly after and not right after, it could very well just be a coincidence. It seems unlikely that the HU would have anything to do with the airbag light.

Were you installing an amp, running wires under the seats or anything? Is it possible the airbag wiring harness got dislodged?



Kunkstyle's Garage:
2006 AWD Pontiac Vibe
Infinity/Rockford/Kenwood Audio, CAI, Cupholder LED's, Keyless Entry Mod

2000 Porsche 911 C2
Kenwood Audio, Ultimate Cupholders, DRL's, 0-60 in 4.9 seconds.

User avatar
kunkstyle
 
Posts: 1236
Joined: Tue Sep 11, 2007 12:51 pm

Postby audiovibe » Tue Jan 06, 2009 6:18 am

Also try to unconnect the battery wait a few seconds and then reconnect, that should reset and clear the code, but if it happens again somethings not right.
Aron
Vibe is gone and will be missed as I've gone country style


User avatar
audiovibe
 
Posts: 1039
Joined: Mon Oct 30, 2006 3:06 pm

Re: (audiovibe)

Postby kunkstyle » Tue Jan 06, 2009 7:15 am

Quote, originally posted by audiovibe »
Also try to unconnect the battery wait a few seconds and then reconnect, that should reset and clear the code, but if it happens again somethings not right.
I was under the impression that that only works on CEL's, not airbag lights.


Kunkstyle's Garage:
2006 AWD Pontiac Vibe
Infinity/Rockford/Kenwood Audio, CAI, Cupholder LED's, Keyless Entry Mod

2000 Porsche 911 C2
Kenwood Audio, Ultimate Cupholders, DRL's, 0-60 in 4.9 seconds.

User avatar
kunkstyle
 
Posts: 1236
Joined: Tue Sep 11, 2007 12:51 pm

Postby audiovibe » Tue Jan 06, 2009 7:45 am

That’s what I thought, Same thing happened when I did my remote start, un hooked battery and hooked it back up and the light went away, could have been a coincidence but it worked for me.
Aron
Vibe is gone and will be missed as I've gone country style


User avatar
audiovibe
 
Posts: 1039
Joined: Mon Oct 30, 2006 3:06 pm

Postby silvrhawk7 » Mon Jan 12, 2009 3:41 am

well, shortly after the discussion was opened, the light went away for some odd reason, and (Knock on wood) has not been back on since. as i was installing the HU, i didnt see any bright yellow wires, nor was i adding any components to the system. I kept the stock Sun and sound package in place for the time being, and unless parts start to fail i dont plan on replacing any of those components anytime soon. (tight budget these days). so thanx to everyone who gave any input on this.

2006 Silver Mono, Base 4-Speed auto, 16" Alloys On Michelin Primacy Tires
Mods?? TBI Coolant Bypass (Thanx V) DRL Bypass, Led Cup holders (Thanx DominosChris), Sony Head Unit
Next on the list: Operation Glasshatch Release.

In Memory of Pontiac Motor Division 1926-2010
In Memory of the Pontiac Vibe 2002-2009
GM, not only have you Lost me as a customer but you have lost millions more....

User avatar
silvrhawk7
 
Posts: 264
Joined: Wed Jan 17, 2007 10:19 am

Re: Airbag Light after HU install

Postby Kerrangsta » Mon Sep 15, 2014 11:27 pm

Here's one, I installed a Pioneer DD with usb into my 2004 Vibe, went for months nd then I received my 3 notice to go in for passive restraint recall, so I finally made the appointment and about 4 days before the service the airbag light comes on. I have 180000 miles on my Vibe and believe it or not it runs great, I also run synthetic and a bit oversized oil filter, but anyways back to the airbag light. My Vibe is worth more to me but not in actual dollars, I may spend a c-note here or there if need be but getting into the airbag system when you have hardl;y any $$ personally is a slippery slope. So we need a new car for my wife, we go and make a great deal on a car and they offer me a deal for my Vibe to get us to buy the 2013 Nissan, so I bite knowing I cannot afford to fix the airbag system if it gets involved, plus what is a Vibe with 180K worth? So I am home getting ready to trade and pull out my Pioneer and slap the stock headset with no display (cause the cro-magnon me decided to smack the radio when the CD skipped, making one side go out, so what did I do, smacked it again to get it to come back on and boom both sides go out) and what do you think happened?
.
.
.
.
.
.
.
The damn airbag light went out!!!

Now IO am stuck driving my wifes leftover Mazda 3 which is a nightmare.

Go Figure
Kerrangsta
 
Posts: 2
Joined: Thu Sep 04, 2008 10:58 am


Return to Audio, Electronics, Electrical

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

x