CEL p2441

Alberta, British Columbia, Manitoba, Saskatchewan

CEL p2441

Postby PhillyVibeGT » Fri Oct 15, 2004 1:14 am

I have an 04 GT with an Injen CAI, ever since I installed the CAI i have had a CEL, the code is P2441..."Secondary Air Injection System Switching Valve Stuck Closed." Is there a way to fix this since the car will not pass inspection with the CEL. For the first few days after the install I had the two hoses going into and out of the VSV backwards, could I of damaged the VSV that way and could that be what is triggering the light? Any help would be great! Thanks
04 GT Satellite Monotone
17'' Fittipaldi Fins on Falkin Azenis ST115's
Moon and Tunes/Sirius Satallite Radio
Injen CAI/Magnaflow Cat-back Exhaust
GM Top Spoiler/Debaged
SilverStar Fogs
"I wasn’t born rich, I’m good looking instead"
User avatar
PhillyVibeGT
 
Posts: 453
Joined: Fri Oct 15, 2004 12:12 am

Re: CEL p2441 (PhillyVibeGT)

Postby SWiRv » Tue Oct 19, 2004 8:41 am

I had a CEL when I first installed my Injen CAI also, but I never took it into the dealership to read the code. My experience is somewhere in the genvibe Engine section so do a search for that. I don't know if you damaged the VSV or not. Disconnect the battery, check your hoses to the VSV and check valve (some may be redundant and not needed) and make sure the black 3/4" vacuum hose to the smog unit is not crimped inside the left front fender (which was the cause of my CEL). Good luck!
"... to boldly go where no one has gone before."

2004 Pontiac Vibe GT
Monotone Salsa
3M Hood Protector Film
Sylvania Silverstars
Injen Cold Air Intake

User avatar
SWiRv
 
Posts: 105
Joined: Tue Apr 13, 2004 3:36 am


Return to Canada - AB, BC, MB, SK

Who is online

Users browsing this forum: No registered users and 0 guests

x