A/C Clutch not engaging...

Discuss any maintenance you've done to your Vibe & Matrix and ask how to perform maintenance on your vehicle
Vibester04
Posts: 16
Joined: Thu Feb 15, 2018 8:56 am

A/C Clutch not engaging...

Postby Vibester04 » Mon Apr 30, 2018 7:12 am

Hey all...

So my A/C quit working a few months after I bought the car... figuring I had a leak, I bought a Red Tek recharge kit and a sealant can. Upon hooking it up, the low pressure side was reading almost 80psi. (It was 28 degrees C in Edmonton the other day, 10-12 the day I recharged.) Replaced relay after I probed the plugs with a testlight. I had power with the ac on and no power with it off... I thought that's what it was, but nope. The compressor clutch spins freely, and the system is accepting new refrigerant (I completely recharges the system to the recommended 45ish PSI). The clutch still will not engage. I'm thinking a low pressure switch has been tripped. What can I do to jump the switch and put 12V to the clutch?

Hopefully this might fix my issues... would the initial high pressure mean I have a clogged line? Help! :roll:

User avatar
joatmon
Posts: 9086
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: A/C Clutch not engaging...

Postby joatmon » Mon Apr 30, 2018 7:00 pm

I don't know about pressure diagnostics

You can command the AC compressor clutch to engage by pulling the AC clutch relay from the underhood fuse block and putting +12V on the pin marked by the yellow arrow in this pic (perhaps by using a bit of wire to connect to the nearby positive battery terminal)

Image

If that doesn't make it engage, then either the clutch is bad (happens more than it should) or you might have a broken wire, which I thought unlikely until I saw Emily's pic in viewtopic.php?f=17&t=46523

Vibester04
Posts: 16
Joined: Thu Feb 15, 2018 8:56 am

Re: A/C Clutch not engaging...

Postby Vibester04 » Mon May 21, 2018 4:16 pm

Update for yall. After I recharged my Fiance' s A.C. (same car), I decided to jump the coil directly at the single wire out of the comoressor. Did on her car first, clutch snapped with excitement! did the same on my car and ...nothing...

Replaced compressor with a $100 wrecker compressor and oiled and recharged it myself, And she blows cold!

User avatar
joatmon
Posts: 9086
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: A/C Clutch not engaging...

Postby joatmon » Wed May 23, 2018 1:20 pm

Vibester04 wrote:Replaced compressor with a $100 wrecker compressor and oiled and recharged it myself, And she blows cold!


Nice! I'll do some things, but that , I'd probably have to pay someone, so congrats, and enjoy the cool


Return to “Maintenance Bay”

Who is online

Users browsing this forum: No registered users and 4 guests