2010 Intermittent No Start

Discuss any maintenance you've done to your Vibe & Matrix and ask how to perform maintenance on your vehicle
Icemanxxxv
Posts: 7
Joined: Tue Mar 01, 2011 5:52 am

2010 Intermittent No Start

Postby Icemanxxxv » Wed Oct 18, 2017 9:02 am

My daughter’s vibe has an intermittent no start issue. Today I went to troubleshoot it and it started. So I’m thinking it’s the pump relay but I can’t find the damn thing.
Thanks for the help.

User avatar
tpollauf
Posts: 3231
Joined: Wed Jan 20, 2010 11:37 am
Location: Toledo/Oregon, Port Clinton Ohio
Contact:

Re: 2010 Intermittent No Start

Postby tpollauf » Wed Oct 18, 2017 11:56 am

Might need a bit more info to guide you in the right direction. Size of engine, trim level, mileage, area car has been used most (north, south, etc.) Ever been wrecked? Would this happen to be the GT you purchased back on 3-3-2011 or did you daughter get her own Vibe? Thanks. We're here to help :)
Image
"everything is modifiable"

Zimm
Posts: 325
Joined: Wed Feb 03, 2010 1:47 pm

Re: 2010 Intermittent No Start

Postby Zimm » Wed Oct 18, 2017 2:41 pm

i'v shared this with man here before:

i've had intermittent no start issues with my 2010. turned out to be a corroded main ground wire from the negative terminal of the battery to the frame. if it no starts, the way to test is to run a jumper cable from the negative terminal and the other end to the frame or something grounded. if it starts no problem, then you need a new main ground cable (cheap, easy fix.)
'10 Black w/1.8L Auto
Air/PW/PL/PM

andrewclaus
Posts: 108
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: 2010 Intermittent No Start

Postby andrewclaus » Wed Oct 18, 2017 3:44 pm

If you suspect the fuel pump system, does that mean it cranks but doesn't 'turn over?'

Is the check engine light on?

Icemanxxxv
Posts: 7
Joined: Tue Mar 01, 2011 5:52 am

Re: 2010 Intermittent No Start Engine Cranks

Postby Icemanxxxv » Wed Oct 18, 2017 5:49 pm

Sorry for the lack of information. The car cranks but will not start. It's a GT around a 150k. It was my car before I gave it to her I got it with just over 100k. I scanned it for codes before I started it and there were not DTC codes. Turned it over and it fired right up. Since there were dtc I'm thinking fuel delivery issues. Now in my experience with fuel pumps is when they quit they quit. Never had one that would not work one day and then work the next. So I was thinking fuel pump relay. Then after using the research data base for my local library the note for the fuel pump relay says it is a pcb based relay and is not serviceable. Leading me to believe It is fixing to get expensive. Anyone know where the circuit opening relay is? fuse block i/p connector x1 pin 8 and 10

andrewclaus
Posts: 108
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: 2010 Intermittent No Start

Postby andrewclaus » Wed Oct 18, 2017 6:36 pm

I'm new to this car too. I have not been able to download a comprehensive wiring diagram.

I did a quick search and found a discrete FP relay for that car, and it looks like it is plugged into the fuse/relay box under the dash.

Normally when faced with a no start, I'd check for spark first. You might have a failing ignition control module. Then I'd find out if it's easy to plug in a fuel pressure gauge. And you might be able to access the fuel pump power wiring at the gas tank, probably under the rear seat.

Icemanxxxv
Posts: 7
Joined: Tue Mar 01, 2011 5:52 am

Re: 2010 Intermittent No Start

Postby Icemanxxxv » Wed Oct 18, 2017 6:43 pm

tpollauf wrote:Might need a bit more info to guide you in the right direction. Size of engine, trim level, mileage, area car has been used most (north, south, etc.) Ever been wrecked? Would this happen to be the GT you purchased back on 3-3-2011 or did you daughter get her own Vibe? Thanks. We're here to help :)

Yes it is the same car no it has never been wrecked it is in the Kansas City MO area.

jolt
Posts: 553
Joined: Sun Mar 02, 2014 2:07 am

Re: 2010 Intermittent No Start

Postby jolt » Fri Oct 20, 2017 11:26 am

I would think fuel pump or fuel pressure control valve, which is part of the fuel pump assembly. Once you loose fuel pressure from the system, you have have to crank the engine for awhile until the pump can bring the pressure back up. The fuel pump on the Vibe only runs when the ECU sees enough rpm's from the engine. The pump does not turn on for a few seconds by turning the key to on; like it does on most cars. Does it only do the start problem if the car sits over night or for a period of time without being ran? When it happens, stop and take something and bang on the fuel tank and then try starting. If it starts after hitting the tank, you have a good sign that it could be a bad fuel pump.

User avatar
lannvouivre
Posts: 1601
Joined: Thu Jun 09, 2011 1:00 pm
Location: Texas yay

Re: 2010 Intermittent No Start

Postby lannvouivre » Fri Oct 27, 2017 4:34 am

Check for power to the pump at key on. Check for spark. Check for fuel injector firing. Check for unobstructed airflow. Also check for codes every time you attempt to start.

Also check the grounds for the ignition system and injectors. They will probably be on the side of the head over the transaxle bellhousing.

I would also suspect loss of pressure via the valve as mentioned above. The pump usually has a valve that prevents pressure from dropping off when the car sits.

There was also a TSB on hard starts when the engine is hot caused by incorrect fuel mapping, but that was a first gen problem.
"If you don't love me at my diddliest, you don't deserve me at my doodliest." - User ktluvscricket of reddit

User avatar
MacGyver
Posts: 336
Joined: Sat Apr 30, 2016 2:45 pm
Location: Ottawa (09 Base)

Re: 2010 Intermittent No Start

Postby MacGyver » Fri Oct 27, 2017 9:42 am

andrewclaus wrote:I'm new to this car too. I have not been able to download a comprehensive wiring diagram.
The wiring diagram for the 09-10 Corolla is pretty close. There are a few things missing like the rear wiper and power inverter, but otherwise everything else is the same. https://www.scribd.com/doc/94557409/200 ... g-Diagrams
2009 Vibe Base

User avatar
MacGyver
Posts: 336
Joined: Sat Apr 30, 2016 2:45 pm
Location: Ottawa (09 Base)

Re: 2010 Intermittent No Start

Postby MacGyver » Fri Oct 27, 2017 9:47 am

Icemanxxxv wrote:My daughter’s vibe has an intermittent no start issue. Today I went to troubleshoot it and it started. So I’m thinking it’s the pump relay but I can’t find the damn thing.
Thanks for the help.


What's the battery voltage with the car off?

Have you considered it could be a bad starter? Here's an example of a bad starter that appears to work correctly, but fails the test machine. https://youtu.be/yC409CU7mU8?t=582

There are some hidden relays, only accessible by removing the radio, HVAC controls, and then taking out two 10mm screws holding the relay panel in. It's face down below the HVAC controls. The fog light relay lives there, among others.
2009 Vibe Base

andrewclaus
Posts: 108
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: 2010 Intermittent No Start

Postby andrewclaus » Fri Oct 27, 2017 10:02 am

MacGyver wrote:
andrewclaus wrote:I'm new to this car too. I have not been able to download a comprehensive wiring diagram.
The wiring diagram for the 09-10 Corolla is pretty close. There are a few things missing like the rear wiper and power inverter, but otherwise everything else is the same. https://www.scribd.com/doc/94557409/200 ... g-Diagrams


Thank you. I've been looking for that for weeks. I've used the Corolla link for some other parts and accessories, but didn't think to use it for a wiring diagram.

Icemanxxxv
Posts: 7
Joined: Tue Mar 01, 2011 5:52 am

Re: 2010 Intermittent No Start

Postby Icemanxxxv » Sun Nov 19, 2017 6:23 pm

Okay more help needed, but first the details. The car cranks just won’t fire off and run. Does this intermittently. Hot, cold, sitting for days no rhyme or reason no set pattern. Sometimes starts right up. Sometimes not. When it doesn’t start the first time it usually takes multiple attempts to get it to start. Drove it 5 miles to Subways went to leave it took three attempts to start pulled it QT not a half mile away for a soda and it fired right up. Changed the fuel pump no help. Did a top end cumbustion cleaning no help. Turns over quiet nicely not a starter or battery problem. It runs strong and performs nicely and smooth. It always cranks fine just wont light off. There are no codes or cel lght. Fixing to take it to a dealer because while I have a scan tool I ain’t got the fancy dealer scan tool, but before I do I would like to have a shot at fixing this myself. Any suggestion out there? Anyone else experience this phenomenon"?
Thanks

andrewclaus
Posts: 108
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: 2010 Intermittent No Start

Postby andrewclaus » Sun Nov 19, 2017 7:40 pm

Have you checked for presence of spark when it's not starting? You can buy a wand for that to make it easier.


Return to “Maintenance Bay”

Who is online

Users browsing this forum: No registered users and 1 guest