04' wont start, no clicking, my blower broke too...same moment?

Discuss any maintenance you've done to your Vibe & Matrix and ask how to perform maintenance on your vehicle
hellracer
Posts: 9
Joined: Wed Dec 08, 2010 11:07 pm

04' wont start, no clicking, my blower broke too...same moment?

Postby hellracer » Tue May 23, 2017 4:09 pm

After driving 1h in the traffic my blower suddenly stopped. It was replaced 2 months ago. I was like, "no big deal" just repair it again....


I had to stop at the grocery but car never started back!!


What do I have the check first?

04 Vibe (manual)

UPDATE: I had to push the car to start it. I checked the purple relay(starter) and is not clicking while turning the key.however I verified it and it is not defective. SO something do not drive the relay.


I can hear click from under glove box.


I have hammered the started without success.

User avatar
vibrologist
Posts: 1430
Joined: Sat May 10, 2014 8:24 am
Location: Iowa

Re: 04' wont start, no clicking, my blower broke too...same moment?

Postby vibrologist » Tue May 23, 2017 8:16 pm

check battery and battery terminals first.
Vibrologist
'05 Vibe

"It is important to know the difference between 'accurate' and 'precise' even if you are neither!"

http://forums.genvibe.com/phpBB3/viewtopic.php?f=30&t=43476

hellracer
Posts: 9
Joined: Wed Dec 08, 2010 11:07 pm

Re: 04' wont start, no clicking, my blower broke too...same moment?

Postby hellracer » Fri May 26, 2017 2:43 pm

Discoverted that my battery connection ground to the engine was corroded. I have completely replaced the wire & plugs. But car still doesnt start ;-(

Is there a way to check if starter work if I pull it?


Return to “Maintenance Bay”

Who is online

Users browsing this forum: No registered users and 1 guest