Battery light dimly lit when running

Stereo, security systems, vehicle electronics, and electrical-related discussions
Post Reply
cthomasparr
Posts: 129
Joined: Sat Jan 16, 2010 10:03 pm

Battery light dimly lit when running

Post by cthomasparr » Thu Sep 27, 2018 4:55 am

I am working on a recently purchased car for a friend and would like to get it back to them. The other day I was test driving it and noticed the battery light was on (fully illuminated). Never went off... regardless of engine speed or accessories on. Voltage at the battery while runnning was <12v.

Picked up a used (tested) original equipment Denso alternator. When I put that in, the light went out... done.. or so I thought. Now it actually appears very very dimly lit. I need to check the voltage at idle. will post that later today.

Anyone know what could be causing this? What is dimly lit indicating? Is an electronic module in the alternator responsible for determining when this light should be on or off?

I went back and cleaned up the connection on the alternator lug and the wire connector, no difference. Maybe a bad ground ( at the alternator bolts/mount ) engine wires? This car is new to me and is low mileage (2004 with 115k) but didn't get the best maintenance.

andrewclaus
Posts: 187
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: Battery light dimly lit when running

Post by andrewclaus » Thu Sep 27, 2018 11:07 am

If it's dimly lit and flickering, it's at the very edge of threshold voltage. You should have a strong 13.8 V or so with no electrical load. Perhaps the used alternator barely passed its test.

cthomasparr
Posts: 129
Joined: Sat Jan 16, 2010 10:03 pm

Re: Battery light dimly lit when running

Post by cthomasparr » Thu Sep 27, 2018 3:27 pm

I just checked as soon as it started up so the idle was higher but the battery posts showed 14.3v. Can there be another reason? Are there grounds that need cleaning? Ground between the alternator and engine?

andrewclaus
Posts: 187
Joined: Tue Oct 03, 2017 6:38 pm
Location: Golden, CO

Re: Battery light dimly lit when running

Post by andrewclaus » Fri Sep 28, 2018 3:21 am

If you were still seeing the battery light with over 14 V at the battery, you got me. That may be a regulator circuit issue, which should be part of the alternator.

If the battery light is intermittent, check the voltage when the light is on, or at curb idle with some electrical load (lights, rear defrost, fan) on it.

cthomasparr
Posts: 129
Joined: Sat Jan 16, 2010 10:03 pm

Re: Battery light dimly lit when running

Post by cthomasparr » Fri Sep 28, 2018 5:16 am

I think I have a plan of attack after a little research. It appears that there is a voltage difference between the ignition and the alternator yellow wire. It is small but enough to illuminate the dash light. The cause for this could be internal to the alternator or as a result of issues in wiring or connections (including fuses) or something defective with the instrument cluster.

My plan is to measure the voltage while running between the battery posts and also separately measure the voltage difference between the alternator large lug and the alternator body/case. If there are differences there, there is a voltage drop somewhere between the alternator and battery. No voltage drop... then maybe I try to measure voltage at the yellow wire. Difference there, alternator malfunction. If all are same, maybe something in dash/cluster is causing issue.

Next step if a difference is found between alternator and batter post measurements is to measure voltage across alternator lug to positive batter post ( looking for a voltage difference of <.5v) and also between alternator case and neg battery post.

If a difference is found between either of those measurements, then I start tracing the paths between the two points and try to isolate where the voltage drop is occurring. Is the alternator case adequately grounded to the engine block. Block to frame... frame to battery. Is the wire from the large alternator lug experiencing a voltage drop across a fuse, the battery post connection....

Any comments appreciated.

cthomasparr
Posts: 129
Joined: Sat Jan 16, 2010 10:03 pm

Re: Battery light dimly lit when running

Post by cthomasparr » Mon Oct 01, 2018 6:02 am

I tested voltage between alt lug and the alternator case 14.5, battery across posts was 14.3, voltage drop between alt case and ground post 0v, voltage drop between alternator lug and positive battery post .15v. All readings normal, voltage drop was <.5v in both cases.

I didn't get a chance to check the voltage on the yellow wire of the alternator harness. If that is < 14.3 then there must be something up with the dash. When I get the car back I will try to measure that.

User avatar
joatmon
Posts: 9212
Joined: Fri Mar 21, 2003 5:19 am
Location: SMC MD

Re: Battery light dimly lit when running

Post by joatmon » Mon Oct 01, 2018 8:54 am

There's an older thread here for the same problem, but if that vibe got it resolved, they never came back to tell us. If you solve this, please let us know the fix.

I didn't see any solutions elsewhere on the net, but folks tend to say its a grounding problem somewhere.

User avatar
cptnsolo77
Posts: 1488
Joined: Sun Jul 29, 2007 4:05 am

Re: Battery light dimly lit when running

Post by cptnsolo77 » Mon Oct 01, 2018 9:34 am

I have the same issue. The battery light is very dim, new alternator and checked the charging system. It all started when I accidentilly drove through a huge puddle ( looked like I parted the red sea :lol: ) Immediately after the felt like it wanted to turn off, battery light came on and just as soon as I said to myself "OH OH" it went away and i continued my drive...however my battery light has remained dimly lit ever since :| Cant figure it out...bad ground due to moisture after driving through the puddle ? I have been recently having a hard start issue when hot also.
* 2003 Vibe Auto Satellite Silver w / Moons & Tunes
* Kenwood Excelon KDC-X597
* Polk DB651-Speakers
* Soundproofcow Roadblock R sound deadening in all doors
* Drop In K & N Filter
* NGK Iridium IX Plugs
* 27 MPG City/Highway with AC on

jolt
Posts: 657
Joined: Sun Mar 02, 2014 2:07 am

Re: Battery light dimly lit when running

Post by jolt » Mon Oct 01, 2018 10:29 am

It could possibly be a weak or bad diode inside the alternator.

User avatar
cptnsolo77
Posts: 1488
Joined: Sun Jul 29, 2007 4:05 am

Re: Battery light dimly lit when running

Post by cptnsolo77 » Sun Jun 16, 2019 2:27 pm

*****FIXED****

Replaced alternator. No more dim battery light. I must have damaged a diode when I drove though that gigantic puddle :lol: From my research Denso provides OEM for Toyota so I purchased a reman Denso alternator.
* 2003 Vibe Auto Satellite Silver w / Moons & Tunes
* Kenwood Excelon KDC-X597
* Polk DB651-Speakers
* Soundproofcow Roadblock R sound deadening in all doors
* Drop In K & N Filter
* NGK Iridium IX Plugs
* 27 MPG City/Highway with AC on

Post Reply