2004 Keyless Entry Remote problems

Stereo, security systems, vehicle electronics, and electrical-related discussions
BustedVibe
Posts: 116
Joined: Sun May 22, 2016 6:27 pm
Location: Wisconsin

2004 Keyless Entry Remote problems

Postby BustedVibe » Tue Jun 19, 2018 8:34 am

Hi all, been a long time since I asked about anything 8-)

Yesterday my windows were cracked while I was inside a store, and it began storming horribly. So I had to run out and get them closed up (still got pretty wet).

That was the last time I know the remote worked. I had it in my hand and it did get wet, but I don't remember if it was working by the time I got home.
Tried replacing battery, no apparent damage on the PCB or anything.

For kicks I tried looking up programming instructions to see if I could rewrite it to the car or something, I've found two sets of instructions, they only differ in terms of how many times to cycle the key from off to on position. (add vs rewrite)

However no matter what instructions I try, the only thing that ever happens is the anti-theft alarm starts going off, at the point where the door locks are supposed to cycle to let you know you are in programming mode.
Image
____________________
2004 Base Automatic

BustedVibe
Posts: 116
Joined: Sun May 22, 2016 6:27 pm
Location: Wisconsin

Re: 2004 Keyless Entry Remote problems

Postby BustedVibe » Wed Jun 20, 2018 9:51 am

Tried everything I can think of, including this post

viewtopic.php?p=430617#p430617

I do everything up to Step 9. Every single time, it sets off the alarm nothing happens with the door locks. Just sits there lights flashing, horn beeping.

I don't get what I'm doing wrong.
From the Service Manual:

Rewrite Mode (deletes old codes and adds new code)
1. Setup:
- ignition is off and key out
- all doors closed except driver door
- driver door unlocked
2. insert and remove ignition key twice within 5 seconds
3. close and open driver door twice in 40 seconds
4. insert and remove ignition key once
5. close and open driver door twice in 40 seconds
6. insert ignition key
7. close driver door
8. turn ignition from LOCK to ON (not START) and back to LOCK 2 times
9. remove ignition key
10. system should LOCK and UNLOCK doors (once or twice) to confirm rewrite mode
11. within 40 seconds simultaneously press the LOCK and UNLOCK buttons of the fob for 1 to 1.5 seconds. Then within 1 second press either the LOCK or UNLOCK button on the fob
12. doors will LOCK and UNLOCK once if code is accepeted. If the they LOCK and UNLOCK twice, the code was not accepted and you need to repeat steps 11 and 12.
13. press and hold either the LOCK or UNLOCK button on the fob for 2 seconds. Doors will LOCK and UNLOCK once if code is accepeted. If they LOCK and UNLOCK twice, the code was not accepted and you need to repeat steps 11 thru 13.
14. to add another transmitter code (up to 4 codes total) repeat steps 11 thru 13.
Image
____________________
2004 Base Automatic

zbyers
Posts: 186
Joined: Thu Apr 03, 2014 6:12 pm
Location: Sheffield, Pennsylvania

Re: 2004 Keyless Entry Remote problems

Postby zbyers » Thu Jun 21, 2018 3:07 am

Are any of the other doors partially open? what about the hatch glass? I'd double check and make sure everything is shut as it should be. I don't believe getting the door or remote wet would cause this to happen. have you tried picking up a new remote just for fun? If you grab a matrix remote, it'll come with the panic button. You can get new remotes for like $15 on ebay/amazon.
Ruby- 03 Salsa, Ray[is]AWD- 04 Salsa AWD, Simon- 03 Silver "Faux by Four"
Raven- 03 Abyss GT, Neptune- 05 AWD, Robyn- 07 Stealth Gray Metallic, Mystic- 09 AWD

GenVibe on Facebook, Everything You Need To Know About Vibes, Great How-To Index

BustedVibe
Posts: 116
Joined: Sun May 22, 2016 6:27 pm
Location: Wisconsin

Re: 2004 Keyless Entry Remote problems

Postby BustedVibe » Thu Jun 21, 2018 6:48 am

Yes I was considering that I likely needed a new remote. I just wanted to make sure I could get it programmed before I went and bought one etc.

Something odd also happened yesterday evening. The anti-theft alarm started going off all by itself. I had to go out and stick the key in the car - that has NEVER happened in the 3 years I've owned this car.

for kicks I fidget with the remote again and then it started working partially. It would lock the doors but the lights would not flash. If I unlocked the doors the lights would, however. The hatch glass button has yet to start working again.

Everything on the car should be secure. But I'm wondering if the remote itself has a short or whatever, either due to age or moisture or something.


Still doesn't explain why I can't get the car to enter programming mode.... I'll have to try again when I get home, with the battery out of the remote, etc.
Image
____________________
2004 Base Automatic

BustedVibe
Posts: 116
Joined: Sun May 22, 2016 6:27 pm
Location: Wisconsin

Re: 2004 Keyless Entry Remote problems

Postby BustedVibe » Thu Jun 21, 2018 1:25 pm

tried doing it again. battery out of the remote so no chance of any interference there.

It just keeps going into the anti-theft alarm. I don't know what I could be doing wrong, I follow all the steps I've found (which are pretty much the same).

I've tried multiple ways of doing the first step. Locking the doors, then unlocking the drivers door (it won't auto unlock when you open the door, don't know if that's a "feature" or not) and opening it. I've tried locking the doors closing the drivers door, opening just the drivers door by turning the key, etc.

Every single time. the alarm triggers no matter what I try to do. faster, slower, etc.

Also just to clarify the remote works "intermittently" sometimes it won't work at all. Could the computer that controls all this stuff have incidentally crapped itself?
Image
____________________
2004 Base Automatic

hogdoctor
Posts: 26
Joined: Sun May 06, 2018 4:28 am

Re: 2004 Keyless Entry Remote problems

Postby hogdoctor » Fri Jun 22, 2018 7:02 am

Odd, the procedure doesn't mention having you lock or unlock any doors, so when is the alarm going off? Just by opening and closing the driver door or when you're putting the key in and out of the ignition hole? Can you confirm any other way that the 'key inserted' switch in the ignition is functioning properly? As for the alarm module, water intrusion in the connector or module itself, or a flaky ground connection somewhere, can result in spooky behavior.

BustedVibe
Posts: 116
Joined: Sun May 22, 2016 6:27 pm
Location: Wisconsin

Re: 2004 Keyless Entry Remote problems

Postby BustedVibe » Fri Jun 22, 2018 10:11 am

Other resources I've seen mentioned the doors had to be locked, with the drivers door unlocked and open.

I just went out there and did it with all doors unlocked, and it worked. The locks cycled, no alarm.

Time for a shopping trip on Amazon
Image
____________________
2004 Base Automatic


Return to “Audio, Electronics, Electrical”

Who is online

Users browsing this forum: No registered users and 2 guests