Water damaged speakers !!!!

Stereo, security systems, vehicle electronics, and electrical-related discussions
User avatar
cptnsolo77
Posts: 1449
Joined: Sun Jul 29, 2007 4:05 am

Water damaged speakers !!!!

Postby cptnsolo77 » Sat Nov 18, 2017 12:28 pm

Wow I havent posted in a while :lol: I have noticed that both my front speakers have not been working for a while, but have been waiting for cooler wheather to diagnose. 3 years ago I replaced all my speakers and insulated with a dynamat knock off. The moisture barrier was removed...from my research it was ok to do. I removed the speakers and guess what ??? water damage !!! Woofers are not working and no movement from the surround sounds like just the tweeters are working. Magnet has rust on them. Now im not sure if its due to now having the moisture barrier OR the window channel seal. I have noticed that some days my drivers seat is damp, I guessing that might be my issue. I was thinking to obviously replace the window channel seal, make my own moisture barrier and place it over the dynamat and buy one of those foam covers for the back of the speaker. That should have me covered. Im thinking it just may be the window channel seal because the rear speakers are fine. I looked inside the door with a flashlight for any traces of water/ stains etc. I used the same soundproofing material for the rear doors and no probs. Any thoughts ?
* 2003 Vibe Auto Satellite Silver w / Moons & Tunes
* Kenwood Excelon KDC-X597
* Polk DB651-Speakers
* Soundproofcow Roadblock R sound deadening in all doors
* Drop In K & N Filter
* NGK Iridium IX Plugs
* 27 MPG City/Highway with AC on

User avatar
ColonelPanic
Posts: 8232
Joined: Sun Jan 05, 2003 8:48 am
Location: South Central Indiana

Re: Water damaged speakers !!!!

Postby ColonelPanic » Sat Nov 18, 2017 9:11 pm

Check derf's thread and video on the subject.

That's what lead to the demise of a cheap pair of Kenwoods I installed. I later noticed that the black trim on the door at the bottom of the glass was pushed toward the rear of the car, leaving a sizable gap at the front. Slid it as far forward as I could, so far so good.
03 Vibe base. Born 10/14/2002 06:07 AM
Neptune. Auto, Moon & Tunes, power package. 130k mi.

Image

'13 Sonic LT - 1.4L ECOTEC turbo/6A. 90k mi.
'15 Escape SE - 1.6L EcoBoost, FWD. 43k mi. (hers)
ImageImage

User avatar
cptnsolo77
Posts: 1449
Joined: Sun Jul 29, 2007 4:05 am

Re: Water damaged speakers !!!!

Postby cptnsolo77 » Mon Nov 20, 2017 8:54 am

Thanks ! I will take a look at that as well 8-)
* 2003 Vibe Auto Satellite Silver w / Moons & Tunes
* Kenwood Excelon KDC-X597
* Polk DB651-Speakers
* Soundproofcow Roadblock R sound deadening in all doors
* Drop In K & N Filter
* NGK Iridium IX Plugs
* 27 MPG City/Highway with AC on


Return to “Audio, Electronics, Electrical”

Who is online

Users browsing this forum: No registered users and 2 guests