Page 1 of 1

2009 Vibe - CEL and Rough Idle

Posted: Fri Dec 22, 2017 7:24 am
by metalgeeksolid
Alright, so I've been dealing with this for a few days now. Right after getting off of the highway the other day, my check engine light came on (not blinking) and the car started idling a little rough. Also, the "VSC Off" light is blinking and the traction control light is on. It continues to drive a little rough but eventually goes back to normal even though the warning lights are still on. I went to Autozone twice in 2 days and got the same P0352 error code:

"Ignition Coil B Primary/Secondary Circuit Malfunction"

Does this mean it's likely a failing ignition coil? Or maybe spark plug?
After a while of not driving I guess the code resets because all those lights go off and everything feels normal, but the whole process eventually repeats over again.

Also, not sure if the car is in limp mode or if it's a cylinder misfire (or both?) but while driving on the highway yesterday I couldn't go over 3k RPM when all the warning lights came on. Again, after pulling off to the side and letting it sit for a bit I could drive like nothing was wrong.

Has anybody run into something like this before? Any advice would be appreciated.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Fri Dec 22, 2017 7:37 am
by Caretaker
sure could be the ignition coil(s). Failing ignition coils often exhibit "comes-and-gos" symptoms, especially when it first begins (Source: fitfreak.net). I replaced all mine at the 95,000 mile mark. How many miles are on your car?

Re: 2009 Vibe - CEL and Rough Idle

Posted: Fri Dec 22, 2017 7:45 am
by metalgeeksolid
It has 101,000 miles. It's due for spark plug replacement as well. I have new plugs but I'm not sure if I should put them in now or wait till after replacing the ignition coil.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Fri Dec 22, 2017 10:37 am
by Caretaker
while I can't speak to these Toyota engines, from my research on the Honda boards, I do know that it would be a mistake to replace just one ignition coil. Replacing all four (with Denso) in conjunction with the spark plugs is just something we have to endure when the time comes.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Mon Dec 25, 2017 12:03 pm
by jolt
Caretaker wrote:while I can't speak to these Toyota engines, from my research on the Honda boards, I do know that it would be a mistake to replace just one ignition coil. Replacing all four (with Denso) in conjunction with the spark plugs is just something we have to endure when the time comes.


Same thing applies to 5.4L Ford pickups. That is why a tuneup at the dealership cost ~$850.00. They know the coils packs will start to go like popcorn popping, so they just say to replace them all at the same time while they have it apart. If the customer does not want to spend the money and replace all the coils, then it is the customers problem and it will cost more later. It is funny that the coils last as long as they do when you think about the coil sitting down in the engine on top of the spark plug and how hot it gets there. Old coils use to sit out in the open and were oil filled to help reduce heat. They also did not put out the high voltage that the new coils do. Coil packs now are just considered a tuneup part; like spark plugs. New car tuneup every ~100,000 miles vs. old car tuneup every ~12,000 miles. The coil packs are cheap when you look at the cost over the life time of the car vs an old '70-'80's car tuneup costs.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Wed Jan 03, 2018 5:32 pm
by tuflehundon
jolt wrote:
Caretaker wrote:while I can't speak to these Toyota engines, from my research on the Honda boards, I do know that it would be a mistake to replace just one ignition coil. Replacing all four (with Denso) in conjunction with the spark plugs is just something we have to endure when the time comes.


Same thing applies to 5.4L Ford pickups. That is why a tuneup at the dealership cost ~$850.00. They know the coils packs will start to go like popcorn popping, so they just say to replace them all at the same time while they have it apart. If the customer does not want to spend the money and replace all the coils, then it is the customers problem and it will cost more later. It is funny that the coils last as long as they do when you think about the coil sitting down in the engine on top of the spark plug and how hot it gets there. Old coils use to sit out in the open and were oil filled to help reduce heat. They also did not put out the high voltage that the new coils do. Coil packs now are just considered a tuneup part; like spark plugs. New car tuneup every ~100,000 miles vs. old car tuneup every ~12,000 miles. The coil packs are cheap when you look at the cost over the life time of the car vs an old '70-'80's car tuneup costs.


Speaking of F150's. On my truck I had to replace just the boots and springs in the coils. Can that be done on these cars? I haven't taken mine apart yet, just got it.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Wed Jan 03, 2018 11:22 pm
by jolt
Yes

Re: 2009 Vibe - CEL and Rough Idle

Posted: Tue Jan 09, 2018 6:40 am
by metalgeeksolid
Update:

My mechanic diagnosed the faulty ignition coil which has been replaced. However, when we started the car up, the battery light now comes on and goes away after a few seconds. He's going to take the alternator and battery to get them tested and also change the battery connectors for me since they look bad.

Is this a pure coincidence that the battery light came on after changing the ignition coil? I find it odd that the light just now pops up when it never did before.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Tue Jan 16, 2018 6:35 pm
by Misanthrope
metalgeeksolid wrote:Update:

My mechanic diagnosed the faulty ignition coil which has been replaced. However, when we started the car up, the battery light now comes on and goes away after a few seconds. He's going to take the alternator and battery to get them tested and also change the battery connectors for me since they look bad.

Is this a pure coincidence that the battery light came on after changing the ignition coil? I find it odd that the light just now pops up when it never did before.



Maybe a failing regulator in the alternator caused an over voltage which stressed the coil.

My Mustang did something like that. It has a volt gauge so I could see it, and I noticed my interior lights got abnormally bright when I reved the engine. Sometimes that can kill the ECU as well.

Re: 2009 Vibe - CEL and Rough Idle

Posted: Thu Jan 18, 2018 11:53 am
by metalgeeksolid
Since replacing the ignition coil and alternator last week I've had zero problems. :D

Now to save up for getting the shocks/struts replaced..