Cabin air button doesn't work

Discuss any problems, warranty, repair, or replacement issues you are having with your Vibe & Matrix
Post Reply
User avatar
wingman7000
Posts: 63
Joined: Mon Mar 30, 2009 5:15 am

Cabin air button doesn't work

Post by wingman7000 » Sun Mar 13, 2011 9:16 am

Some time ago the cabin air button stopped working in my '03 GT. The vents allow air to pass no matter what I do, even in the off position. Any idea as to why this would happen?

User avatar
ColonelPanic
Posts: 8353
Joined: Sun Jan 05, 2003 8:48 am
Location: South Central Indiana

Re: Cabin air button doesn't work (wingman7000)

Post by ColonelPanic » Sun Mar 13, 2011 10:14 am

Hear any thumping coming from the top right of the dash, in the area near the air bag?Sounds like your recirculate motor might have failed and left the damper wide open. If it's on fresh air, it would still flow air through on the outer vents even when off.Below is a thread outlining the replacement. The part is fairly reasonably priced and is doable yourself (but I found very difficult!) You can get to it by just taking out the radio, glove box, etc but it's very tight.http://forums.genvibe.com/zerothread?id=24332
03 Vibe base. Born 10/14/2002 06:07 AM
Neptune. Auto, Moon & Tunes, power package. 136k mi.

Image

'13 Sonic LT - 1.4L ECOTEC turbo/6A. 121k mi.
'15 Escape SE - 1.6L EcoBoost, FWD. 61k mi. (hers)
ImageImage

User avatar
wingman7000
Posts: 63
Joined: Mon Mar 30, 2009 5:15 am

Re: Cabin air button doesn't work (ColonelPanic)

Post by wingman7000 » Sun Mar 13, 2011 10:48 am

I haven't heard any thumping, but I've always heard a little buzzing/vibration sound coming from the dash and it sounds like it comes from the right side. I thought it may have been a relay or something, but what you're saying makes sense. I'll have to check it out when I have some time, especially if I have to take the dash out.

User avatar
lovemyraffe
Posts: 4288
Joined: Sun Oct 07, 2007 3:08 am

Re: Cabin air button doesn't work (wingman7000)

Post by lovemyraffe » Sun Mar 13, 2011 11:40 am

My first thoughts are...is the air selector on the defrost? If it is, you shouldn't be able to select the cabin air. Second, there is a cable that is connected to the back of that button that won't let you select it if you have the defrost selected. If this came off, you won't be able to select it either.
March 2011 MOTMFebruary 2010 MOTM My GenVibe garage

User avatar
wingman7000
Posts: 63
Joined: Mon Mar 30, 2009 5:15 am

Post by wingman7000 » Sun Mar 13, 2011 10:11 pm

No, its not on defrost. It went out about a couple of years ago and I've turned every knob I can to see if it would work and nothing. I figured that since I remembered this site when my clutch started slipping I would find out about other issues I've been having. This community is awesome and everyone is great about helping out. I'll probably be posting more questions soon, assuming I don't find the answer already posted.

User avatar
zionzr2
Posts: 3174
Joined: Tue Jul 27, 2004 4:59 am
Location: Austin, TX

Post by zionzr2 » Mon Mar 14, 2011 4:15 am

I just had the recirc motor replaced by a shop it cost me just under $500. yikes.Mine kept trying to push the door open to outside air when in that position(VERY ANNOYING THUMPING). in the cabin air mode it was silent

User avatar
wingman7000
Posts: 63
Joined: Mon Mar 30, 2009 5:15 am

Post by wingman7000 » Wed Mar 16, 2011 8:53 pm

Anyone know the part number for the recirc motor? I looked on the list here in genvibe, but didn't see it.

jake75
Posts: 4792
Joined: Sun Feb 09, 2003 1:33 pm
Location: Columbus, OH

Re: (zionzr2)

Post by jake75 » Wed Mar 16, 2011 11:52 pm

Quote, originally posted by zionzr2 »I just had the recirc motor replaced by a shop it cost me just under $500. yikes.Mine kept trying to push the door open to outside air when in that position(VERY ANNOYING THUMPING). in the cabin air mode it was silentYes yikes - a couple years ago the dealer replaced the recirc motor on my '03 (assume it included the motor - not the fan motor though) - cost was about $80 for the part and $100 labor. I don't have the details as I gave all the service records to the person that bought my '03.
2009 Vibe 1.8L Carbon Gray AT Power Pkg 1/12/092003 Vibe 1.8L Neptune AT Mono Power Pkg 1/27/03 [sold 2/2/09]2007 T&C SWB 7/31/07 "Broke people stay broke by living like they're rich. Rich people stay rich by living like they're broke."

Post Reply