VSC, Trac and engine light come on after 09 Vibe overnights in rain

Discuss any problems, warranty, repair, or replacement issues you are having with your Vibe & Matrix
WileECoyote
Posts: 3
Joined: Tue Jun 26, 2018 7:31 am

VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby WileECoyote » Wed Jun 27, 2018 8:34 am

So, my 09 Vibe 2.4l 5 speed has the three lights of doom come on with varied codes read each time it happens. The one common code it has is P0607 (Control Module Performance) along with P0136 (second o2 sensor bank one) or C1201 (engine Control Module Performance).
This only happens when it sits for at least 8 hours and its been raining. No rain=no problem. driving in the rain, sitting in the rain while at work for 8 hours or whatever, no problem.
I've read multiple threads on here about various folks having similar issues, but I can't seem to find a solution. I found a TSB that says to seal the rear O2 sensor where it runs next to the evap case in the center console, but that doesn't make sense as sometimes this happens when no A/C has been used in months. I looked there anyway and cannot find an 02 sensor wire anywhere near the throttle pedal under the center console. I have disconnected and used dielectric grease on various sensors and connectors in order to attempt to seal them from the elements, but no difference

Im at wits end

WileECoyote
Posts: 3
Joined: Tue Jun 26, 2018 7:31 am

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby WileECoyote » Thu Jun 28, 2018 9:08 am

And today’s code P0138. I think I’ll replace the rear O2 sensor and see how that goes

zbyers
Posts: 291
Joined: Thu Apr 03, 2014 6:12 pm
Location: Sheffield, Pennsylvania

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby zbyers » Mon Jul 16, 2018 4:02 am

With the 2nd gens, supposedly the rear ABS sensors get corroded and when they get wet, the whole christmas tree lights up.
Ruby- 03 Salsa, Ray[is]AWD- 04 Salsa AWD, Simon- 03 Silver "Faux by Four"
Raven- 03 Abyss GT, Neptune- 05 AWD, Robyn- 07 Stealth Gray Metallic, Mystic- 09 AWD

GenVibe on Facebook, Everything You Need To Know About Vibes, Great How-To Index

WileECoyote
Posts: 3
Joined: Tue Jun 26, 2018 7:31 am

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby WileECoyote » Fri Aug 03, 2018 3:46 am

Replaced the secondary O2 sensor, three rain sessions later and still no check engine lights have returned. Seems as though Pontiac/Toyota have an issue with the other codes for the ECU and disabling the TCS system whenever anything triggers a code!

User avatar
SeattleJeremy
Posts: 933
Joined: Mon Jun 05, 2006 4:02 pm
Location: Seattle, WA

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby SeattleJeremy » Fri Aug 03, 2018 8:35 am

WileECoyote wrote:Replaced the secondary O2 sensor, three rain sessions later and still no check engine lights have returned.

Glad you got that sorted.
WileECoyote wrote:Seems as though Pontiac/Toyota have an issue with the other codes for the ECU and disabling the TCS system whenever anything triggers a code!

This is actually a safety feature. The computer understands there is a problem, and throws the code for the system it thinks is causing the fault. The computer also does not want to accidentally start controlling traction when it's not needed (even if the fault is not in TCS/ABS) so it turns the Traction Control System off.

EDIT: In the early 00's my 96 Grand Am had an engine speed sensor failure, and the traction control system went crazy. This was because the info the computer was getting from the engine/transmission was different compared to the TCS/ABS system.
06 Vibe Base - Mono Platinum - Manual

Glenpointe
Posts: 23
Joined: Mon Aug 17, 2009 7:50 am

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby Glenpointe » Tue Sep 04, 2018 6:14 am

I have exactly the same problem with my 2009 with 2.4L engine 5sp automatic. I got caught in a heavy rain few days ago, and my check engine light turned on and my VSC off light flasing. However, the lights turned off the next day. It rained again last night and the same lights turned on today. It stored 2 codes. P0138 and P0607. I am baffled why does the O2 sensor trigger this code after rain? The only thing that I can think of is the O2 connector got wet and shorted out. And after you drive a car for while, it dries out and everything is OK. I bet the O2 is still good, but the connector seal is deteriorated overtime. Wondering if I can seal the connector or I need to replace the O2 sensor?

zbyers
Posts: 291
Joined: Thu Apr 03, 2014 6:12 pm
Location: Sheffield, Pennsylvania

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby zbyers » Wed Sep 05, 2018 3:46 am

Glenpointe wrote:I have exactly the same problem with my 2009 with 2.4L engine 5sp automatic. I got caught in a heavy rain few days ago, and my check engine light turned on and my VSC off light flasing. However, the lights turned off the next day. It rained again last night and the same lights turned on today. It stored 2 codes. P0138 and P0607. I am baffled why does the O2 sensor trigger this code after rain? The only thing that I can think of is the O2 connector got wet and shorted out. And after you drive a car for while, it dries out and everything is OK. I bet the O2 is still good, but the connector seal is deteriorated overtime. Wondering if I can seal the connector or I need to replace the O2 sensor?


You could definitely add some dielectric grease to the connector and see if that stops the problem. i'd also check the wire right at the o2 sensor to see if it's cracked or anything.

it is definitely a well known issue that the 2nd gen lights up the fourth of july in wet weather for some reason. my dad's has done it a few times and thrown the code for the cam sensor, but has no issues otherwise.
Ruby- 03 Salsa, Ray[is]AWD- 04 Salsa AWD, Simon- 03 Silver "Faux by Four"
Raven- 03 Abyss GT, Neptune- 05 AWD, Robyn- 07 Stealth Gray Metallic, Mystic- 09 AWD

GenVibe on Facebook, Everything You Need To Know About Vibes, Great How-To Index

Glenpointe
Posts: 23
Joined: Mon Aug 17, 2009 7:50 am

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby Glenpointe » Wed Sep 05, 2018 9:28 am

trying to disconnect the O2 sensor 4-way connector yesterday and couldn't able to do it. It's one hand operation, trying to push down the locking tab and at the same time pulling the connector but could not able to do it so I gave up after one hour. Any suggestion?
Thanks,
Glen

hogdoctor
Posts: 57
Joined: Sun May 06, 2018 4:28 am

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby hogdoctor » Thu Sep 06, 2018 1:09 am

sometimes a bit of debris gets stuck under the plastic tab that you have to push down to unlatch it. If they give me trouble, I'll blow out the area with my air nozzle and it usually lets me disengage the clip.

GORGO
Posts: 15
Joined: Sun Aug 05, 2018 1:47 pm

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby GORGO » Thu Sep 13, 2018 3:08 pm

That just happened to me this AM when leaving work.I work nights.The Vibe sat for about 10 Hrs.I have been driving the last couple months thru rain.I started it & all the same lights lit up.
Everything was good when I left for work but was driving thru rain & a lot of standing water. I did notice the Transmission was shifting a little odd on the 16 mile trip home.One of my co-workers has a scanner so Im gona pull the codes this weekend.I have been reading thru all the threads on this & there seems to be a lot of different answers/fixes.Im a Class 8 Tractor/trailer mechanic & do my own Vehicle maintenance.My vibe is a 09 base with the 1.8 automatic with under 50k miles.Im just gona drive my 96-F150 4x4 into work tonight.

GORGO
Posts: 15
Joined: Sun Aug 05, 2018 1:47 pm

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby GORGO » Sat Sep 15, 2018 8:24 am

Pulled the codes,the scanner only went up to 08,but did get two codes
PO 456 Small leak in e-vac,figured that cause the CEL to come on after sitting 10 hrs & it does that gas vapor E Vac.
C 2911,see service manual,anybody know what that is ? I did remove all the TPS sensors a couple years ago.L couldn't clear that.
I cleaned the gas cap & filler neck as suggested in one of the above posts., cleared the PO 456 code,it only set that once.
I gota go out this afternoon so ill drive the vibe,park it overnight & see what happens.
BTW,after I cleared the PO code the traction control icon & the blinking VSC lights went off.

GORGO
Posts: 15
Joined: Sun Aug 05, 2018 1:47 pm

Re: VSC, Trac and engine light come on after 09 Vibe overnights in rain

Postby GORGO » Sat Sep 22, 2018 10:38 pm

UPDATE.
After cleaning the cap & 0 ring & driving all week the CEL light never set.We can't pump our own gas in NJ so sometimes I forget to check the cap.I did notice the cap doesn't click & return sometimes so Im gona order a new cap.Hope this helps somebody.Reading the posts helped me & I just tried the easiest thing to do 1st Happy trouble shooting & good luck.


Return to “Problems & Warranty Issues”

Who is online

Users browsing this forum: No registered users and 2 guests