AC Works Great and Then Stops

General discussions about the Pontiac Vibe & Toyota Matrix. New members, introduce yourself here!
woodworker
Posts: 8
Joined: Sat Dec 06, 2014 7:28 pm

AC Works Great and Then Stops

Postby woodworker » Mon Aug 06, 2018 1:58 pm

AC works great part of the time with cooooold air. Then other times nothing. I can't seem to find a pattern to it. Sometimes it works when I start up the car, other times I start up the car and it doesn't matter how many miles I go, it won't get cold. Then other times I will start up the car and after several miles it will get cold. The only consistent seems to be that once it is cold, it stays cold as long as I'm driving the car. I don't think this has anything to do with it, but it started immediately after I had the serpentine belt changed. Any ideas on what this may be? 2004 1.8L automatic. Thanks

User avatar
Caretaker
Posts: 1549
Joined: Sun Dec 14, 2003 4:11 am

Re: AC Works Great and Then Stops

Postby Caretaker » Mon Aug 06, 2018 3:54 pm

On the Fit boards, a common issue with their AC units acting up is normally one of two things:

1. the level of refrigerant is not at the proper level. There is a high and low gauge range which needs to be tested. It is likely that you need to get the refrigerant to the proper charge.
2. when the AC runs for too long a time, the lines actually freeze up, requiring the driver to run the car without the AC on for a few minutes to allow the hot air to unfreeze the lines.
Live it up: There will be plenty of time to be old when you die.
** 2009 Vibe: 1.8 liter automatic **
** 2010 Hyundai Elantra Touring **
** 2007 Honda Fit Sport **

User avatar
SlammedNiss
Posts: 231
Joined: Tue Apr 02, 2002 1:11 pm

Re: AC Works Great and Then Stops

Postby SlammedNiss » Tue Aug 07, 2018 12:17 am

When you cycle the AC button on the dash, can you hear the AC compressor kick on? As stated, it might be low levels of coolant, but you might also need to replace the relay that controls the compressor. Had to do that a couple years back when mine was doing the exact same as you describe. It would work great at times, and other times not so much.
2003 Matrix Xrs Automatic

woodworker
Posts: 8
Joined: Sat Dec 06, 2014 7:28 pm

Re: AC Works Great and Then Stops

Postby woodworker » Thu Aug 09, 2018 5:19 pm

Thanks for the input. I took it to the mechanic and they called and said it was fine, nothing wrong with it, AC running great. I got there and it wouldn't get cool, which has been the pattern. When it goes to cool it will stay nice and cold until sometimes when it's turned off or car turned off, and then it will only blow warm. So, mechanic said probably the relay and changed that out. Said it was running hot, and I believe he said compressor was hot too (couldn't hear it exactly), but then said either the compressor is overworking the relay causing it to run hot, or the relay is bad and causing the compressor to overwork. Since changing the relay it has been fine, and interestingly is what I call a "normal" cold. Before, it was super cold whenever the cold was working. So maybe the compressor was overworking. Anyway, I'm hoping the relay is all it is. Thanks again for the input. It was a great help in letting me know what I was possibly getting into. Intermittent problems are so frustrating.


Return to “The Vibe Lounge”

Who is online

Users browsing this forum: No registered users and 3 guests